SOLVED: V2 - Symbol’s function definition is void: org-back-to-heading-or-point-min

I’m on Win10. Migration to V2 was not successful for me (Selecting deleted buffer error).

So I’ve removed all files related to V1 (didn’t have much to loose), deleted the db file. Then installed V2, updated the config but I’m getting Symbol’s function definition is void: org-back-to-heading-or-point-min error now, also after manually invoking org-roam-setup.
org-roam-db-sync throws Selecting deleted buffer

Here’s my config excerpt.

;;; Tell Emacs where sqlite3.exe is stored
 (add-to-list 'exec-path "~/../../Dropbox/Sync/MyOrgMode/bin/")

(use-package org-roam
      :ensure t
      (org-roam-directory (file-truename "~/../../Dropbox/Sync/MyOrgMode/org-roam/"))
      (org-roam-dailies-directory (file-truename "~/../../Dropbox/Sync/MyOrgMode/org-roam/daily"))
      (org-roam-completion-ignore-case 1)
      :bind (("C-c n b" . org-roam-buffer-toggle)
             ("C-c n /" . org-roam-node-find)
             ("C-c n g" . org-roam-graph)
             ("C-c n i" . org-roam-node-insert)
             ("C-c n c" . org-roam-capture)
	     ("C-c n j" . org-roam-dailies-capture-today)
             ("C-c n t" . org-roam-dailies-find-today))
;;      (org-roam-buffer-width 0.2)
;;      (org-roam-link-title-format "R:%s")
      ;; If using org-roam-protocol
      (require 'org-roam-protocol)

(setq org-roam-v2-ack t)

I’ve checked the documentation but have no idea what else I could try. Any suggestions are welcome. Thanks in advance!

BTW, installation on Android Termux/Emacs went fine and I’m able to use org-roam there with just one small oddity.

what’s your org mode version? I suspect you might be running 9.3 or before. Org-roam requires 9.4 onwards (the v2-ack warning now should say it too).

1 Like

This should be a separate issue. On Windows every second call to db-sync gets this; it has been a quirk of emacsql for Windows. But with V2 (and V1), I never see this error in daily usage. You call db-sync only once when you start Org-roam (via org-roam-setup).

Thank you @nobiot! Indeed the upgrade of org-mode solved the problem.

I am using straight with default setting. org-mode is 9.3 for me. How to update it to 9.4

I think upgrading Emacs to the latest release 27.2 is the easiest.

27.1 still comes with 9.3.

I have no idea how Straight works.