org-roam-db-sync: Symbol’s function definition is void: file

Hi All,

I am running Org mode version 9.5.2 (9.5.2-gfbff08 @ /home/ds/.emacs.d/elpa/org-9.5.2/)

with 2.2.1 of org-roam.

Mostly everything was working ok (since an earlier v2 upgrade), but I
wasn’t using the =org-roam-buffer-toggle= function.

When I tried to use =org-roam-buffer-toggle= function I got this error:

org-roam-buffer-render-contents: Wrong type argument: characterp, (“CATEGORY” . “20210506152625-openbsd”)

org-roam-buffer-render-contents: Wrong type argument: characterp, (“CATEGORY” . “20211119164404-my_openbsd_laptop”)

I then upgrade to org-roam 2.2.0 since I’m not sure if 2.1.0 is compatible with org 9.5.2 (is there a document somewhere which says which roam versions should be mixed with which org versions?).

Since doing that, when I try initiate org-roam, by using this:

(require 'org-roam)
(setq org-roam-directory “~/src/ds-org/”)
(setq org-roam-completion-everywhere t)
(setq org-roam-db-location “~/.cache/emacs/org-roam.db”)

org-roam-db-sync: Symbol’s function definition is void: file

How can I troubleshoot this further?

Thought you were using Spacemacs?
I’d suggest to try vanilla with no config other than org-roam and org.

This looks like a very low-level issue, which suggests to me that either your Emacs or Org is not properly installed, or something very basic is not working.

I believe this is copy and paste from your Slack issue (?) I do not how you upgrade from v2.2.1 to v2.2.0? I’m not saying it should be “downgrade” but how did you install v2.2.0 after you had v2.2.1? It’s not easy to do with built-in package.el, so it might give us more clue.

Edit: Looks like the latest version of Org-roam is v2.2.0 so I suppose you are on it not v2.2.1? This does not change my suggestion: try vanilla (no Spacemacs, no user configuration; just Org and Org-roam)

Hello. No I was and am on plain emacs with own config.

Yes, I posted here first, but it wasn’t approved so posted something on slack.

But it’s solved. I basically switched from version in melpa-stable to version in melpa and all came right.

Thank you!

1 Like

I didn’t know this forum had an approval; it didn’t when I joined…