Org-roam buffer is empty

I recently installed org-roam in Ubuntu and getting started. I did read the man pages and commands and felt there was something missing in way I understood backlinks.

Here is example I used M-x org-insert to insert warsaw . org
====contents of curie . org
#+Title: curie
Marie Curie was a Polish and naturalized-French physicist and chemist who
conducted research.

She was born in file:…/…/org-roam/ warsaw which was part of Russian empire.

==== contents of CAPTURE-2021…
#+title: warsaw
Warsaw is the capital of Poland.

Now I go back to curie . org and type in M-x org-roam-buffer-activate the buffer opens up empty.

My understanding was the links “warsaw . org” should show up in the org-roam buffer. Is this correct?

I tried similar examples - but do not see the links in org-roam buffer. Please let me know if I am using right commands.

  • within curie . org I navigate to word warsaw and C-c C-o - it opens up 202101…
  • I tried M-x org-roam-db-build-cache too.

I want to appreciate all the work done to this package.

This suggests to me that the buffer has not been saved into your filesystem yet. Try C-c C-c to commit your capture. Automatic update of the cache DB is done when you save the buffer.

You may like to read through some more material to get started with Org-roam. This section of the official user manual has a quick walk-through of the system. I have also started documenting basic elements of Org-roam to complement the official user manual. This chapter on the capturing process might be useful to you.

Thank you, the C-c C-c made it work. I will use this as reference and try another example to understand this better.

1 Like