My expectations of "Unlinked References" must be off

I was really excited to read about “unlinked references”, but have unable to get it to work the way I thought it would.

I have a roam note titled “Leadership”. I have another note titled “Ideal Department” which contains the word “Leadership” in text, but not as a link. When I am in the “Leadership” note if I run org-roam-unlinked-references I expected to see “Ideal Department”, but the list of unlinked references is empty.

What exactly does unlinked references do if not that? I watched the video a while ago, thought that was what it was showing. I assumed there may have been a bug so I let some patches go out. Got caught up in life and tonight tried it again. I am still seeing the same thing.


It should work exactly the way you described it. Do you have ripgrep installed? That is what it uses under the hood.

I’ll give it a try again and see if I can reproduce.

Yes, I have ripgrep installed. Using doom-emacs (updated yesterday) on Emacs v 27.1 with org-roam 1.2.1.

This is what I am seeing:


It’s working for me:

Is your ripgrep compiled with pcre2 support?

one way to check if it’s working properly is by running the rg-command in the terminal. You can do C-h org-roam-unlinked-references, and navigate to the code. Then, instrument the function with C-u M-x eval-defun, and run org-roam-unlinked-references. After stepping through the process, you can find the value of rg-command, copy it and run it in any terminal.

1 Like

I know it is an old topic, but I’ll let it here for future searches.

org-roam-unlinked references uses ripgrep and maintainers of ripgrep explicitly don’t recommend installing it through packet manager in ubuntu. Their explanation:

(N.B. Various snaps for ripgrep on Ubuntu are also available, but none of them seem to work right and generate a number of very strange bug reports that I don’t know how to fix and don’t have the time to fix. Therefore, it is no longer a recommended installation option.)

For me, although the version of ripgrep seemed correct on terminal, I was having the message about lack of support for ripgrep.

It was solved for me when I removed the package through packet manager and reinstalled it through the binary file provided.