Killing backlinks buffer

Hi all, I’m trying to integrate org-roam into my note-taking workflow. One thing that is a a constant pain point is that when I kill my org-roam note buffer (or switch to another buffer), the backlinks buffer remains behind, and I have to kill it explicitly. This is pretty intrusive. Is there a way to fix this behavior?

Answering my own question: automatic popping up of the backlinks buffer is actually a “helpful” feature provided by Doom, as mentioned here – Option to only show backlinks buffer ("sidebar") on command · Issue #1286 · org-roam/org-roam · GitHub. Bringing it under manual control makes the situation better.