Help understanding new org-roam buffer (V2)

I’m having trouble understanding the new org-roam buffer. I don’t know if this is a problem with my setup or intended and I’m not getting it. This is my org-roam buffer:

Now what I don’t understand is, I’m currently viewing the “work” org file, this file has 1 backlink in “index” which it correctly states. However the only link that is available points to “work” and the “index” entry isn’t a link. So i can only navigate to the same buffer i’m currently in. Is this intended and I’m overlooking something?

What will happen if you put your cursor somewhere on “index” and press Enter (or Return)? A mouse click won’t work by default.

Well Return for me does nothing but that’s a seperate issue that can be fixed, but it should invoke “org-roam-visit-thing” right? Doesn’t work. I’ve tried all the different “org-roam-visit-*” functions, none of them do anything anywhere in the backlinks section.

For now, turn off page-break-lines-mode

Thank you very much :slight_smile: that fixed it

I had the same issue, but after disabling global-page-break-lines-mode I still have the weird formatting. Here’s the other modes I have enabled (I use spacemacs so there’s a ton of stuff here, sorry)
Screen Shot 2021-07-21 at 2.48.41 PM
Does any of that jump out at you as something that could cause the same formatting issues?