Backlinks title not at top of buffer

It is happening for all backlink buffers. Has anybody else encountered anything like this? (org-roam-diagnostics included in screenshot.)

1 Like

Yes. My guess is that it started happening due to this change introduced about 8 days ago – org-roam-buffer is going through some revamping by the looks of it. It might appear a little strange for now, but I don’t see any loss of functions at the moment so I am letting it be.

I would love to give Jethro and the project some time to focus on org-roam-buffer revamping effort and upcoming new design change.

If you have the means, and the sequence is more than inconvenience to you, I think you could roll back to a commit before the change happened.

:pray: Thanks for confirming & agreed re: providing time & space for v2.

1 Like

@zbodtorf,

Turning off global-page-break-mode fixed the ordering issue of *org-roam-buffer* for me. This slack post gave me the clue; it also has a config you could use if your issue is the same, and you wish to continue to use page-break-mode.

For me, I just removed the pacakge – I did not need it. Perhaps worth a try on your end.

Thank you – I’ll check it out!

I am using Spacemacs and turning off (global-)-page-break-lines-mode doesn’t seem to work. I found out a workaround in case it is helpful for Spacemacs users.

2 Likes

Here is a workaround by modifying the ~/.spacemacs without touching org-roam code:

  1. If you toggled dotspacemacs-line-number, please modify it as
   dotspacemacs-line-numbers '(:t
	                           :disabled-for-modes org-mode)
  1. add the following to dotspacemacs/user-config()
(fset 'evil-redirect-digit-argument 'ignore)
(add-to-list 'evil-digit-bound-motions 'evil-org-beginning-of-line)
(evil-define-key 'motion 'evil-org-mode (kbd "0") 'evil-org-beginning-of-line)
(global-page-break-lines-mode -1)

(defun display-line-numbers-customize ()
	(setq display-line-numbers 'visual))
(add-hook 'org-mode-hook 'display-line-numbers-customize)
(advice-add 'org-roam-buffer-persistent-redisplay :before
			  (lambda () (remove-hook 'org-mode-hook 'display-line-numbers-customize)))
(advice-add 'org-roam-buffer-persistent-redisplay :after
			  (lambda () (add-hook 'org-mode-hook 'display-line-numbers-customize)))

Replace'visual with t or 'relative based on your preference.