Unable to compile mysql on windows

I’ve installed doom emacs on windows, and I get

(error No EmacSQL SQLite binary available, aborting)

I realize that this usually indicates a missing GCC to compile the custom mysql - but I’ve installed GCC throught mingw, and I’ve verified that I can call it from windows command line - and I still get the same error.
I’d really appreciate it if someone could help me debug this…

It’s probably missing PATH environment variable.

It was the first thing I checked… :slight_smile:

Jonathan@DESKTOP-KVVLOPE MINGW64 ~/Desktop
$ which gcc

Jonathan@DESKTOP-KVVLOPE MINGW64 ~/Desktop
$ echo $PATH
/c/Users/Jonathan/bin:/mingw64/bin:/usr/local/bin:/usr/bin:/bin:/mingw64/bin:/usr/bin:/c/Users/Jonathan/bin:/c/WINDOWS/system32:/c/WINDOWS:/c/WINDOWS/System32/Wbem:/c/WINDOWS/System32/WindowsPowerShell/v1.0:/c/WINDOWS/System32/OpenSSH:/c/Program Files/Polyspace/R2019a/runtime/win64:/c/Program Files/Polyspace/R2019a/bin

Depending on how you installed Emacs, it may be worth checking if you can call gcc from cmd program. The path you show above may be only readable within MinGW (?). I have the following noted down, which does not seem to be part of your PATH(?) I use MSYS2 and install GNU Emacs official binary (not installed through MSYS2). MinGW would be different but maybe…


I’ve also installed the official windows binary of emacs, not through mysys.
I’m running git bash, and have installed gcc through the mingw installer…
How would you chcek that gcc is callable from a cmd program?

Perhaps call “gcc” directly?

The note I took is as follows:

On Windows, add C:\msys64\usr\bin (command where gcc in MSYS2 terminal can tell you the directory) to PATH in your environmental variables