SOLVED: `emacsql-sqlite3` no longer available from MELPA

[irrelevant, deleted]

[Edit: The following sentence is incorrect.] This seems to mean nobody can install org-roam unless they’ve already got a copy of emacsql-sqlite3.

Here’s the git log from the Melpa repo for when they deleted emacsql-sqlite3:

commit 769ccff0d4d686bb9444a2a2531b1bc0646c5de4                                      
Author: Jonas Bernoulli <>                                           
Date:   Sat Mar 4 10:58:40 2023 +0100                                                
    Remove recipe for emacsql-sqlite3
    This package won't work with EmacSQL 4.0.0, which also removes the
    need for this.

D       recipes/emacsql-sqlite3

The github issue mentioned in the comment, suggests that switching to EmacsSQL 4.0.0 shouldn’t be hard, but I don’t understand it.

You don’t need emacsql-sqlite3. It’s one of the four options. I have used emacsql-sqlite since the beginning. With Emacs 29, you can use emacsql-sqlite-builtin even on Windows.

Haha you’re right! Thank you, @nobiot! I’ll move this from Development to Troubleshooting and mark it as solved.

EDIT: Just to spell things out, what solved this for me was to installemacsql-sqlite (by listing it in my NixOS configuration file) and not mention anything about sql in my .emacs config file.

1 Like