Problems with installing V2

I’ve followed the excellent Rough Guide, but I’ve been having some difficulties…
I’m still getting 1.2.3 when running org-roam-version, although I did check the repo and it points to the V2 branch. Is that normal?
When installing, I eventually deleted all org-roam dirs from the .emacs.d tree, and ran doom sync to get it to re-clone and re-build the package.

The second issue is that running the migration script gives me “device 1 is not a termcap device”, any clue where to look for solving/understanding it?


No, not normal. Your emacs is still using v1.2.3. This means you still have v1 source and/or compiled file. You might not have deleted the correct tree under straight dir?

No idea what the second issue is….

I have the termcap error as well and couldn’t solve it so far. I guess you’re on Mac, right?

This might give you a hint?

@J0ns4, if it’s a Doom issue for the migration script, I think you can run it with emacs -Q (not loading Doom) or the batch mode and directly load the script .el file like emacs -batch -l [script .el file] .

Thanks @nobiot. I actually ended up removing the whole of .local dir and reinstalling doom - but it still didn’t change anything… I’ve also tried to pin the package to a specific commit like someone suggested in the slack channel, but it’s still the same :confused:

That seems to suggest that the way you point to the branch incorrect?

The Hitchhiker’s Guide has this for Doom:

(package! org-roam 
  :recipe (:host github :repo "org-roam/org-roam" :branch "v2"))

Also… perhaps you have +roam option for org in your init.el, which might interfere with your manual package!? – you would need to remove the option, I think.

That’s actually exactly how it is (was) in my packages.el - I’ve changed it to

(package! org-roam :recipe (:host github :repo “org-roam/org-roam”) :pin “8bed015cdff44bc813cad5c9cbe0194026d53370”)

And I’ve already removed the +roam flag from init.el

1 Like

Sorry, no idea.

After reading your reply, I just installed v2 into my test Doom Emacs on my VM running Ubuntu by copy-and-paste this:

(package! org-roam 
  :recipe (:host github :repo "org-roam/org-roam" :branch "v2"))

~/.emacs.d/bin/doom sync (without the -u option).

V2 is working fine; org-roam-version returns 2.0.0.

Thanks for trying to reproduce!
I don’t understand it at all… maybe I’ll try re-installing doom again. Is there any compiled binary of the package that I maybe forgot to remove?
Can I verify which location of org-roam is loaded?

Thanks again!

You may have another package that has org-roam as a dependency. I had this issue and solved it removing company-org-roam.

1 Like