Org-roam backlinks not recognized after migration to V2

Hi there,

I’m using Doom-emacs latest, and i’m trying to migration from org-roam V1 to V2.

I run the following scripts, i think with success :

My doom config :


  :recipe (:host github :repo "org-roam/org-roam" :branch "v2"))
(unpin! org-mode)
(unpin! org-roam)


(use-package! org-roam
  :after org
  (setq org-roam-mode-sections
        (list #'org-roam-backlinks-insert-section
  (setq org-roam-directory (file-truename "~/Notes/2ndBrain/")
      org-roam-db-location (file-truename "~/Notes/org-roam.db")
      org-roam-link-title-format "%sº"
      org-roam-prefer-id-links t
      org-roam-index-file "")

I have :

  • properties ID at heading of each org file
  • no error
  • Links are written like this : [[][Litterate Programming]]

Exemple :sob:

So, as you see, my org-roam-buffer contain only the current node, and nothing else …

Any idea why ?

Use [[id:uuid-of-node][descrption]] instead.

Thanks @nobiot but all my links are v1 like that, is there any script to replace automaticaly old link with new link format ? I suppose lot of people are in the same case …

Look at Jethro’s script. Not at PC now; see the Hitchhiker’s Rough Guide for a link. There should be a couple of threads both in Discourse and Slack.

Just to complement @nobiot’s answer, here are the links:

1 Like

Hum, i already run a migration script, but probably not the good one (see my first post), so i need to go back to v1 to migrate my file, then move again to v2 to run other part of the script. I will try that …

After you run the migration script and still has links like you reported in your first post, then the migration script didn’t work for that particular file; it’s a little hard to believe it worked for none of your files.

You don’t need to go back to to v1 Org-roam. The problem is your notes and not Org-roam. Going back to v1 does not change anything for your note files.

I would try to see what part your notes causes the migration script to fail.

By the way, I don’t see “migration script” in these two bullet points…?? I could be wrong; It’s not easy to see for me. Sorry.

Did you try this one?

Yeah you right, i probably misunderstand the Hitchhiker's Rough Guide to Org roam V2 · org-roam/org-roam Wiki · GitHub, thinking this snippet of code updating the actual link to id.

I need to move to org-roam v1 to rerun the script because some part of the script of @jethro use a function only available in V1 … (step 1)

Edit 1 :

Ps : for doom people, if you had problems to run doom sync -u after changing to v2 in packages.el, run rm -rf ~/.emacs.d/.local/straight

1 Like