Org Roam and Logseq - Files created by Logseq not showing up in org-roam-node-find

Any sugestions as to why am I not finding my Readwise booknotes from Logseq?

I have set myself up with Logseq and Org-Roam in accordance with the article here.

I also have Logseq with its Readwise Plugin syncing my Kindle Notes to Logseq. These files are in .org format. I then run org-roam-logseq.el which turn notes that were created with Logseq into org-roam nodes. (The above is described in the linked article above.

When I run org-roam-node-random it finds and opens these book notes.

But when I run org-roam-node-find it only finds notes I have created myself. It is not finding all my book notes inside /Google Drive/org/roam/Logseq/notes. This is also where new capture notes are create.

I am on Doom emacs. The relevant bits will be in config.el and org-roam-logseq.el. My config is on gitlab here:

Did you adjust the directory variable to your own?

(defvar bill/logseq-folder (f-expand (f-join org-roam-directory "zettel")))

Sorry for the long wait to reply. And thanks for reply. I had the directory variable set up okay. The issue turned out to be coming from the Readwise plugin. It would make the first level orgmode header of the Kindle Highlights to be Synced from Readwise into the #+Title for Org Roam. So I had hundreds of files with the title Synced from Readwise which was not very useful.

So I had to go into the Logseq Readwise Plugin and select custom and set the first header as follows.

Screenshot from 2023-05-21 18-53-37

Now when I search I can find all my org-roam files.

1 Like

Glad that you have found a solution. I am not able to connect the problem and solution you describe, but I guess that’s because I don’t use the tools you use and am not familiar with them.