Migrate-wizard gets to 72% and then returns error

It returns

Wrong type argument: arrayp, nil

and then none of my files show up when I do org-roam-node-find

I also tried org-roam-setup and that also gets to 72% before returning the same error.

I commented out everything regarding roam from my config. And I’m on doom emacs latest version.

Any help would be huge because otherwise I have no idea what I would do

It’s probably caused by data in one or some of your notes – e.g. you specified #+ROAM_ALIASES or #+ROAM_REFS with no value.

If I were you, I would try 3 things, probably in this order (because it’s easier to try 1 than 3).
The objective is to find an/some offending note(s).

  1. Turn on toggle-debug-on-error and run the same thing. It might give you the file name that causes this issue
  2. Use grep or ripgrep (or whatever file search program you can use) to look for ROAM_ALIASES, ROAM_REFS, etc. to see if there is any one that has no value
  3. Move half of the notes somewhere else, and run the same thing. Repeat this to narrow down the number of notes, and try to find which file(s) cause the error

If you have headings with IDs, you might need to do this per node, rather than the file.