Cryptic (invalid read syntax: #, 12, 719) when org-roam-node-find


I am using the latest org-roam, org-roam-ui and doom emacs and I’d be grateful for hints on how to debug one error I am facing.

When I run org-roam-node-find, all I get is the message (invalid read syntax: #, 12, 719). Nothing else at all. org-roam-ref-find, instead, offers me a list of REFS to jump to.

I thought I managed to solve it yesterday by removing some custom configurations around org-roam-node-display-template, but the problem has re-appeared today. This morning, having fiddled a bit more, it seems to work again. However, I don’t know why it broke and why it now works.

My question is: is there a way to get a slightly more verbose error message if the problem reappears? toggle-debug-on-error is of no help here.

Thank you very much!


1 Like

Hi meccanus, I am experiencing the same issue (invalid read syntax: "#", 43, 1147) with org-roam-node-find and org-roam-node-capture but not org-roam-ref-find. What exactly did you do to fix it? Have you made any progress on locating the issue since?

FWIW I do not have any cutom configuration for org-roam-node-display-template

Unfortunately I couldn’t identify the root cause of the issue. When it happens, I tend to delete the database and let org-roam regenerate it. Things then work for a bit. Let me know if you have any hints or make any progress on this!

Huh, yeah clearing the database with org-roam-db-clear-all and org-roam-db-sync seemed to work. Still no idea why this happened.