HELM mode not used first time using org-roam-node-find

When emacs first starts and I run org-roam-node-find, it uses the default emacs Completions mode. If I instead run helm-find-files, then run org-roam-node-find, I get the proper HELM Org Roam Node Find mode from then on.
I’m presuming this is an issue with my config files somewhere, could anyone point me towards where I could go look to try and get helm used straight away?

That sounds like helm-mode is not turned on before org-roam-node-find.
I think you somehow defer activation of helm-mode.
Calling helm-find-files loads helm, whereas org-roam-node-find does not.
I suggest to check your autoloading mechanism (use-package or doom’s use-package! macro ?)

Alternatively, perhaps you could put (helm-mode t) at the beginning of your init file, I guess.

After a bit of googling, adding

(require 'helm)

to my use-package org-roam script fixed the problem. Thanks @nobiot

I initially tried adding :after helm to my use-package org-roam part, which just broke my org-roam installation for some reason.