Broken links, even thou links are not broken

Hello everyone :slight_smile:

I’m constantly having problems with org-roam when trying to export files, Emacs keeps telling me that the link to the file is broken and that it can’t find the ID, even thou the file is not broken and the link is not broken, as when I actually click on the link in Emacs, it successfully opens the link, so i’m confused as to why this is happening, and why it won’t let me export, even thou the links are working … I’v tried org-roam-db-sync … doesn’t fix the issue … any ideas to why this is happening and how to solve it?

I literally, rewrote my entire notes from scratch, created new links and backlinks, and it still gives me the same error

This? Org-roam V2 / org-id ID link resolution problem - #15 by jes

I would suggest that you copy the exact error message and search in this forum. I remember there were similar issues that you report and collectively we should have a solution here on this forum. It’s just there are a couple of variations and the exact error message should tell you you/us which one.

Also… I don’t export Org files so I can’t really remember much in this area.