Backlinks not showing up

Emacs 27.1
Org 9.4.6
Roam 2.0.0
I have a fresh install of emacs, with the following in my .emacs

(require 'package)
(add-to-list 'package-archives
             '("melpa" . "") t)
(add-to-list 'package-archives '("org" . "") t)
(setq org-roam-directory (file-truename "~/org-roam"))
(setq org-roam-v2-ack t)
(require 'org-roam)

I have run M-x package-refresh-contents, then M-x package-install RET org-roam RET.

org-roam–sqlite-available-p is set to t.

In ~/org-roam I have two files: with

* first item

I created this link with org-roam-node-insert with

:ID:       06f4f8e6-fcb6-461a-bd0b-753013a71c56
#+title: first-node

I created this file with org-roam-node-find. Running org-open-at-point on the link in takes me to I have finalised the capture and saved both files.

When I open the first-node file and run org-roam-buffer-toggle, the roam buffer appears, but it does not display the backlink.

I have tried everything I can think of to get this to work. Any suggestions?

The only thing I could suggest is to ensure to finish the capture process C-c C-c, and then ensure to save the note. For both, but especially the one you create via the insert command.


Thanks for the suggestion. I have finished the capture with C-c C-c and saved both files.

Any other suggestions much appreciated. :slight_smile:

What does the link look like? Sorry you might have written it above, but I’m lost in what’s linked what and how…

One other thing you could try is to run org-roam-db-sync manually. See what happens.

Thanks. Tried org-roam-db-sync - doesn’t throw up any errors, but backlinks still do not appear.

Link looks like:

Sorry no idea… I have not had any problems with backlinks…

Bump! Anyone have any ideas by any chance?