Wrong type argument: integer-or-marker-p, nil when adding a link

Dear all,

When saving my org-roam file, I get the following error:

Error (org-roam): Failed to process /home/xxxx/Documents/Org_Roam_Notes/journal/2023-07-26.org with error Wrong type argument: integer-or-marker-p, nil, skipping...

The content of the file is the following:

:ID:       a0f45239-38cd-40bc-9c35-df717e60f825
#+TITLE: 2023-07-26
#+FILETAGS: Journal
* 10:29: [[id:a42f73ca-1ab1-41e5-9f17-7b6258f1a1e6][Topic]]
** Some other content

If I remove the link to ‘Topic’, the error disappears. Can someone help?

I can’t reproduce the situation or error. This works on my end.

Do you have the latest Org-roam version? Not from the MELPA-stable, but from MELPA.

If not, I suggest you update it.

I’m using straight with git and am on tag v2.2.2 having this issues. I tried commit 5c0647 (same as on melpa), but still the same issue.

Seems to be the same issue as Wrong type argument: integer-or-marker-p, nil · Issue #2361 · org-roam/org-roam · GitHub

For now I was able to solve by fixing org-mode to tag ‘release_9.5.5’.