V2 Daily Folder

I have installed org-roam V2 and am trying to use dailies. The problem I’m having is that I configured a dailies directory, but no matter what I put in, it always wants to put them in the same (different location) place. Here is my org-roam config (I’m using doom emacs). I have this installed on Mac and Windows and have the same problem on both platforms.

I’ve tried using a relative path because that seemed like what the default indicated, and I tried an absolute path. All with the same result.

(use-package! org-roam
  :after org
  (setq org-roam-directory "~/OneDrive/emacs/org-roam/"
        org-roam-file-extensions '("org")
        org-roam-dailies-directory "dailies") ;Iteration 1
        ;org-roam-dailies-directory "~/OneDrive/emacs/org-roam/dailies/") ;Iteration 2
        ;org-roam-dailies-directory "/Users/mtw/OneDrive/emacs/org-roam/dailies/") ;Iteration 3

In case it matters, this is my org config as well

(use-package! org
  (setq org-attach-id-dir (concat default-directory "attachments")
        org-attach-dir (concat default-directory "attachments")
        org-startup-with-inline-images t
        org-log-done 'time
        org-support-shift-select t
        org-startup-folded t))

And here is where I set any default directories (this is actually at the beginning of my config.el)

(setq org-directory "~/OneDrive/emacs/org/"
      default-directory "~/OneDrive/emacs/")

Whenever I call org-roam-dailies-find-today or org-roam-dailies-capture-today it always prompts me with this:

Directory '/Users/mtw/OneDrive/emacs/daily/' does not exist! Create it? (y or n)

Hopefully from this someone can see what I’m missing.

In case anyone is wondering, it looks like this was fixed in commit 534a3de. It is working correctly now.

1 Like