V2 - Case insensitive completion and backlinks not working as expected

Hi,

I’m trying the Org-roam V2.

While testing my notes, I’ve noticed two things that are not working:

  • Case insensitive search after inserting [[; the search works if I write the title as is,
  • Backlinks buffer is weird (screenshot attached) and there are no links to the files.

How can I fix this?

Edit: by disabling packages one by one, found that it was conflicting with the emacs-dashboard package, which I disabled for now.

For your insensitive search issue, two suggestions:

  • Try variable completion-ignore-case
  • Raise GitHub issue on defcustom org-roam-completion-ignore-case
    Your issue indicates it’s not working on v2 now. It’s either still to be implemented or to be deprecated.

For your second issue of org-roam-buffer, it looks to me that you have all the elements to be displayed; however, they are displayed in the wrong order. It looks to me the same problem as this one on Slack

Suggestions:

  • Ask Milan what he might have done to solve it; he didn’t come back to Slack
  • Add more description how others might reproduce it on their end
    I don’t have the same issue, so have no idea. You would really need to provide a step-by-step description and your environment (e.g. Doom, Spacemacs, what commit of v2 you are on, etc.).

Thank you for your reply!

I’m running Windows 10 - Emacs 27.2 and using my own custom settings. I use Straight package manager and set it up to use the v2 branch from Github.

I’ve ran the migration.el script to convert my notes from v1 to v2.

This is my complete settings for org-roam:

(straight-use-package
 '(org-roam :type git :host github :repo "org-roam/org-roam" :branch "v2"))

;; Recommendation for Windows users for performance
(setq org-roam-db-update-method 'immediate)

;; Set the org-roam directory
(setq org-roam-directory "D:/orgmode")
(setq org-roam-index-file "D:/orgmode/index.org")

;; Ignore case when auto completing
(setq org-roam-completion-ignore-case t)

(require 'org-roam)
(org-roam-setup)
(add-hook 'after-init-hook 'org-roam-mode)

;; Add the auto-completion backend to company backends
(add-to-list 'company-backends 'company-capf)

Not sure what you are expecting by sharing your config.

For the insensitive issue, try to see if my suggestions work. For the org-roam-buffer order issue, it looks like the cause is in the other parts of your config. I would turn off everything else and see if I could locate it.

Other than these suggestions, I don’t think I can do much else. I’m on vacation with no laptop.

Thank you for your help. I found that it was a conflict with the emacs-dashboard package. For now I disabled the dashboard but I wonder if anyone else has the same conflict.

1 Like