Org Roam Keybindings not showing up on Doom emacs


I have been facing this problem for a while where the regular keybindings for Org roam have not been working for some reason. I have tried uninstalling org-roam, doom emacs multiple times to fix this. I’m not sure what is going.

Doom emacs version:



Apologies for another question related to doom emacs. I have a feeling this has something to do with it, as i couldn’t find any thread related to this on discourse or on reddit. I will move on to vanilla emacs plus evil mode soon to avoid such problems in the future. In the meanwhile, i’d appreciate any help from other users who may have faced a similar problem.

Thank you.

Are you installing roam by adding the +roam2 flag to org in doom/init.el?

That is correct

Do any keybindings show up in the function help for them? In doom you can get to the help for a function with SPC h f

So I reinstalled doom emacs again, and it worked this time. Not sure what happened, but I’ll close this thread for now.