Org roam error, "Error running timer"

What ever org-roam command the run I get the following error Error running timer: (error "Selecting deleted buffer").

This Doom Emacs install is on a fresh Ubuntu 22.04.3 LTS, and I have also tried Ubuntu 23.10.1 (Mantic Minotaur) and still the same error.

This is my org-roam configuration:

(use-package! org-roam
  :ensure t
  (setq org-roam-v2-ack t)
  (org-roam-directory "~/RoamNotes")
  (org-roam-completion-everywhere t)
    '(("d" "default" entry "* %<%I:%M %p>: %?"
       :if-new (file+head "%<%Y-%m-%d>.org" "#+title: %<%Y-%m-%d>\n"))))
  :bind (("C-c n l" . org-roam-buffer-toggle)
         ("C-c n f" . org-roam-node-find)
         ("C-c n i" . org-roam-node-insert)
         :map org-mode-map
         ("C-M-i" . completion-at-point)
         :map org-roam-dailies-map
         ("Y" . org-roam-dailies-capture-yesterday)
         ("T" . org-roam-dailies-capture-tomorrow))
  ("C-c n d" . org-roam-dailies-map)
  (require 'org-roam-dailies) ;; Ensure the keymap is available

And this is the backtrace of the error:

  set-buffer(#<killed buffer>)
  (save-current-buffer (set-buffer buf) (org-reveal '(4)))
  (closure ((buf . #<killed buffer>)) nil (save-current-buffer (set-buffer buf) (org-reveal '(4))))()
  apply((closure ((buf . #<killed buffer>)) nil (save-current-buffer (set-buffer buf) (org-reveal '(4)))) nil)
  timer-event-handler([t 25958 838 237811 nil (closure ((buf . #<killed buffer>)) nil (save-current-buffer (set-buffer buf) (org-reveal '(4)))) nil nil 85000 nil])

I have tried the following:

  • Delete the org-roam-db and then run org-roam-db-sync.
  • Going into emacsql directory >> sqlite and running make.

Thank you all in advance.

Is this similar / same?

I suspect it is related to Doom using an unreleased version of Org.

Is this you on Reddit and you have found a solution?

Yeah, thank you so much for the help, and I am sorry for not checking on the forum.

1 Like