Problem with org-roam-protocol

@nobiot I will make an experiment with -c option as you suggest, just to be sure, and then I will make the PR … however this will happen after 3 June 2024, because I will be away for a few days.

Thank you. Any time you can :slight_smile:

FYI. This may be relevant as a future reference for Mac users wanting to use emacs as a daemon: pel/doc/emacs-daemon.rst.txt at master · pierre-rouleau/pel · GitHub

Hello @nobiot ,

I have tried using option -c with following configuration:

  • .emacs does not contain (server-start)
  • I start emacs from command line with emacs --daemon
  • I modified the script to include -c option when invoking emacsclient as you suggested here Problem with org-roam-protocol - #20 by nobiot

With this configuration everything works.

So, I guess there are two options:

  1. use the configuration described above
  2. include (server-start) in .emacs and then you do not need the -c option when invoking the emacsclient in the script, you do not need to start emacs with --daemon

Do you still want me to do a pull request to update the documentation? If so, should I try to describe the two options in the documentation?

@nobiot I created a PR Update by marcosbodio · Pull Request #2441 · org-roam/org-roam · GitHub

1 Like

Awesome :slight_smile: