Org-roam-migrate-wizard, "Selecting deleted buffer"

I’m trying to migrate to v2 using org-roam-migrate-wizard. My experience has been that it manages to do one or two files, then tops with the error:

Org-roam will now convert all your notes from v1 to v2.
This will take a while. Are you sure you want to do this? (y or n) y
Backing up files to /home/caleb/Dropbox/org/org-roam.bak
Saving file /home/caleb/Dropbox/org/notes/
Wrote /home/caleb/Dropbox/org/notes/
helm-M-x-execute-command: Selecting deleted buffer

Annoyingly, to try again, I have to delete org-roam.bak manually. Anyway, I’ve tried a couple times, and this is always the result. I found a couple issues on github that might be relevant, something about emacsql-sqlite3 perhaps?

I tried removing org-roam and deleting the .db manually, then reinstalling, to no avail.

I use spacemacs, on the develop branch, and just pulled. My whole config is here: Configs/.spacemacs at master · komali2/Configs · GitHub

Any ideas? The “Selecting deleted buffer” error persists, and forces a full emacs restart to do anything else, because all commands that involve buffers will instead cause the above error.

GNU Emacs 27.1 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.23)
of 2020-12-14
Spacemacs v.0.300.0
Ubuntu 20.10
Gnome 3.38.3

Another issue on github:

You might like to try this.

was having the same issue, but disabling global-git-gutter+-mode (as recommended in the migration guide) before running the wizard solved it for me.

Nice, didn’t see that! Wish it had popped up in my googling. Thank you!

What if I get the same message but don’t have git-gutter installed at all?

It would depend on how you get the error message.

My suggestion would be:

  1. Follow and monitor the GitHub issue I referenced above
  2. Describe your particular circumstance step-by-step to see if anyone can jump in to help you (here and/or GH issue)
1 Like